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Introduction

The Silicon Expert User’s Guide contains detailed information about 
using the Silicon Expert tool of the Designer Series software.

Silicon Expert reads in a netlist (.edn) file, and allows you to optimize 
designs for Actel devices, translate designs into various EDIF flavors, 
print out a timing report of your optimized design, and write an 
optimized structural netlist for place and route with Actel’s Designer.

Also included in this guide is a tour that describes usage examples of 
Silicon Expert. Refer to the Designing with Actel manual for additional 
information about using the Designer software.

Document Organization
The Silicon Expert User’s Guide is divided into the following chapters:

Chapter 1 - Design Flow contains information describing how Silicon 
Expert integrates into a schematic-based or a synthesis-based design 
flow.

Chapter 2- Macro Manager gives detailed information about the 
Macro Manager feature of Silicon Expert.

Chapter 3- Translate gives detailed information about the Translate 
feature of Silicon Expert.

Chapter 4- Design Report gives detailed information about the 
Design Report feature of Silicon Expert.

Chapter 5- Touring Silicon Expert gives examples of using Silicon 
Expert.

Appendix A - Menus, Commands, and Shortcut Toolbar gives 
detailed information about the menus, commands, and the shortcut 
toolbar used in Silicon Expert

Appendix B - Read Netlist Dialog Box gives detailed information 
about the Read Netlist dialog box of Silicon Expert

Appendix C - Write Netlist Dialog Box - gives detailed information 
about the Write Netlist dialog box of Silicon Expert
vii



Introduction
Appendix D - Product Support - Provides information about 
contacing Actel for customer and technical support

Document Assumptions
The information in this manual is based on the following assumptions:

1. You have installed the Designer Series software and the Silicon 
Expert tool. If you need to install Designer Series software and 
Silicon Expert, refer to the installation instructions in the Designing 
with Actel manual.

2. You are familiar with UNIX workstations and UNIX operating 
systems, or with PCs and Windows operating environments.

3. You are familiar with FPGA architecture and FPGA design software.

This manual uses screens from the PC version of Silicon Expert. UNIX 
screens appear slightly different, but the functionality is the same.

On-Line Help
The Designer Series software comes with on-line help. On-line help 
specific to each software tool is available in Designer, ACTgen, 
ACTmap, Silicon Expert, and APS. 

Context 
Sensitive 
On-Line Help

Silicon Expert features context sensitive on-line help. Context-sensitive 
on-line help lets you point to any item on the screen and get specific 
information on that item.

To use context sensitive on-line help, do one of the following:

• (PC only) Choose the Help button on the toolbar, place the cursor 
over the item on the screen you need help with, and then click the 
left mouse button. An informational pop-up topic will appear.

• (PC only) Place the cursor over the item on the screen you need help 
with, and press the F1 function key. An informational pop-up topic 
will appear.
viii
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• Place the cursor over the item on the screen you need help with, and 
click the right mouse button. This displays the “What’s This” pop up. 
Click the left mouse button. An informational pop-up topic will 
appear.
ix





1
Design Flow

This chapter contains information about how Silicon Expert fits into a 
typical Actel schematic- or synthesis-based design flow. Also contained 
in this chapter is an overview of Silicon Expert.

Schematic- or Synthesis-Based Design Flow
The Actel schematic- or synthesis-based design flow has four main 
steps; Design Creation/Verification, Design Implementation, 
Programming, and System Verification. A typical design flow using 
Silicon Expert is shown in Figure 1-1.1

1. Actel-specific utilities/tools are denoted by the grey boxes in Figure 1-1.

Design Creation/Verification

Data I/O

System General

Fuse
File

Actel
Device

BP Microsystems

SMS Sprint

Design Implementation

Programming

System Verification

Compile

Layout

DT Edit PinEdit

DT Analyze ChipEdit

ExportFuse

Silicon Explorer

Timing
File

Structural
Netlist

Library
Synthesis

EDIF
Netlist

3rd Party Synthesis 
or 

ACTmap
Simulation Tool

Behavioral/Structural/Timing
Simulation

Behavioral
HDL

Libraries
VITAL/Verilog

ACTgen
Macro Builder

Silicon 
Expert
(Optional)

Schematic
Entry 
Tool

APS2/APSW Software
Activator 2/2s Programmer

Silicon Sculptor

Figure 1-1. Silicon Expert Design Flow
1



Chapter 1: Design Flow
Silicon Expert can be used during design creation to add I/Os to a 
design or balance buffer trees. Silicon Expert can also be used after 
design creation to translate a structural netlist from one format to 
another. For more detailed information about typical Actel synthesis- 
and schematic-based design flows, refer to the Designing With Actel 
manual.

Overview of Silicon Expert
This section provides an overview of the Silicon Expert tool. More 
detailed information can be found in the chapters “Macro Manager” on 
page 7, “Translate” on page 13, “Design Report” on page 15, “Touring 
Silicon Expert” on page 21, and “Menus, Commands, and Shortcut 
Toolbar” on page 39.

Silicon Expert reads in a netlist (.edn) file, and allows you to optimize 
designs for Actel devices, translate designs into various EDIF flavors, 
print out a timing report of your optimized design, and write an 
optimized structural netlist for place and route with Actel’s Designer.

Invoking Silicon 
Expert

Perform the following steps to invoke Silicon Expert on a PC or UNIX 
workstation.

PC
From the Windows Start bar, click Programs, click Designer R2-1998, 
and click the Silicon Expert icon in the Designer R2-1998 program 
group.

UNIX
From the command line, type the following:

expert

This will invoke the Silicon Expert window. The Silicon Expert 
window displays log and timing report information about the netlist. 
The Silicon Expert window is shown in Figure 1-2. 
2



Overview of Silicon Expert
Refer to “Viewing a Report” on page 18 for information on Timing 
Reports displayed in the Silicon Expert window.

Figure 1-2. Silicon Expert Window

From the Silicon Expert window, you can observe the progress of 
design optimization, and read reports. 

You can clear the information displayed on Silicon Expert window by 
clicking the clear command in the Edit menu.

When you invoke the Silicon Expert program, the Getting Started 
dialog box is displayed, as shown in Figure 1-3. 

There are three choices in the Available Tools portion of the Getting 
Started dialog box: 

• Macro Manager

• Translate

• Design Report
3



Chapter 1: Design Flow
Check the appropriate button and click OK. This will invoke the Read 
A Netlist Dialog Box. Refer to “Read Netlist Dialog Box” on page 45 for 
information about reading a netlist.

You can also check the Read the last Netlist box and click OK to open 
the netlist on which you last worked.

Figure 1-3. Getting Started Dialog Box

The following are descriptions of I/O Macro Manager, Translate, and 
Design Report features of Silicon Expert.

Macro 
Manager

Macro Manager allows you to perform the following tasks to optimize 
your Actel designs:

• Insert, replace, or correct pads

• Insert global clock on selected networks

• Buffer high fanout nets and rebuffer networks

For more detailed information about Macro Manager, refer to “Macro 
Manager” on page 19.
4



Overview of Silicon Expert
Translate Translate allows you to translate a structural netlist from a given format 
into a different format.

The Translate function can read EDIF, Verilog, and ADL netlists, and 
translate them into EDIF, Verilog, VHDL, or ADL netlist formats. For 
more detailed information about Translate, refer to “Translate” on page 
25.

Design Report Design Report generates a report with the following information:

• Utilization of chip resources, such as number of sequential and logic 
modules

• Worst/longest timing paths in the design

For more detailed information about Design Report, refer to “Design 
Report” on page 27.

Read the Last 
Netlist Box

The Read the last Netlist check box allows you to open the last netlist 
you worked on in Silicon Expert. Check this box, and click OK, and 
the last netlist you worked on will be read into Silicon Expert.

Show Getting 
Started Dialog 
Check Box 

The Show Getting Started check box allows you to display the Getting 
Started box the next time you invoke Silicon Expert. If the box is 
checked, the Getting Started dialog box will display the next time you 
invoke Silicon Expert. If the box is not checked, the Getting Started 
dialog box will be disabled the next time you invoke Silicon Expert.
5





2
Macro Manager

This chapter describes in detail the features of the Silicon Expert
Macro Manager.

Macro Manager enables you to take full advantage of architecture-
specific features of Actel devices. With Macro Manager, you can:

• Perform pad/registered pad insertion for designs with no pads or 
pads inserted on only a portion of the design.

• Balance, replace or correct buffer trees.

• Insert buffer trees for high fanout nets.

• Utilize global resources such as CLKINT, QCLKINT, for reset/preset 
networks or high fanout nets.

• Perform complex netlist enhancement tasks.

• Incorporate expertise within the system to carry out all operations 
autonomously.

Using Macro Manager
You can invoke Macro Manager three ways:

1. Select Macro Manager from the Getting Started Dialog Box. Refer to 
“Show Getting Started Dialog Check Box” on page 5 for information 
on how to use the Getting Started Dialog Box.

2. Select Macro Manager from the Tools menu. Refer to “Menus, 
Commands, and Shortcut Toolbar” on page 39 for information on 
how to use the Tools menu.

3. Invoke the Macro Manager Wizard. Refer to “Macro Manager 
Wizard” on page 43 for information on how to use the Macro 
Manager Wizard.

Read a Netlist When Macro Manager is invoked, the Read Netlist dialog box is 
displayed if a netlist has not yet been read in. Select the netlist you 
wish optimize, and open it. Refer to “Read Netlist Dialog Box” on page 
45 for information on the Read Netlist dialog box.
7



Chapter 2: Macro Manager
Description of Macro Manager Features
When a netlist is read into Macro Manager, the I/O Macro Manager 
dialog box is displayed, as shown in Figure 2-1. 

The I/O Macro Manager dialog box can also be displayed by selecting 
the I/O Macro Manager command in the Tools menu. Refer to “Tools 
Menu” on page 40 for more information on the Tools menu. 

Figure 2-1. I/O Macro Manager Dialog Box

I/O Macro 
Manager 
Dialog Box

This section describes in detail the features of the I/O Macro Manager 
dialog box (Figure 2-1).

The I/O Macro Manager dialog box consists of the following 
spreadsheet columns and buttons:

Port Column
The Port column lists by name all of the ports found in the design.

Direction Column
The Direction column lists the port direction. If the port does not drive 
any cells, the word “UNCONNECTED” is displayed.
8



Description of Macro Manager Features
Original I/O Column
The Original I/O column displays the I/O Macro if it has already been 
inserted on the port. A blank indicates that an I/O Macro does not exist 
on the port.

Current I/O Column
The Current I/O column displays the best I/O macro for the given port, 
as suggested by Silicon Expert.

Use Seq I/O 
The Use Seq I/O column appears if the design has latches directly 
connected to the I/O ports and if they can be combined for a latch I/O 
cell. Use this column to de-select the latches if you do not wish to use 
the latch I/O cells. 

I/O Instance Name Column
The I/O Instance Name column displays the name of the I/O Macro.

Next Button
Click the Next button when you are finished with the I/O Macro 
Manager spreadsheet.

Finish Button
Click the Finish button to finish the design with all actions performed 
up to this point.

Cancel Button
Click the Cancel button to cancel changes to your design.
9



Chapter 2: Macro Manager
Buffer Manager 
Dialog Box

When you are finished with the I/O Macro Manager dialog box and 
click the Next button, the Buffer Manager dialog box is displayed, as 
shown in Figure 2-2.

The Buffer Manager dialog box can also be displayed by selecting the 
Buffer Manager command in the Tools menu. Refer to “Tools Menu” 
on page 40 for more information on the Tools menu. 

This section describes in detail the features of the Buffer Manager 
dialog box.

Figure 2-2. Buffer Manager Spreadsheet

The Buffer Manager dialog box consists of the following spreadsheet 
columns and buttons:

Network Type Column
The Network Type column lists the type of the network.

Network Driver Column
The Network Driver column lists the hierarchical pin name of the 
driver of the network.

Buffers on Network Column
The Buffers on Network column lists the total number of buffers on the 
network.
10



Description of Macro Manager Features
Original Fanout Column
The Original Fanout column lists the total number of pins driven by 
the network. The buffers on the network are ignored.

Max Fanout Column
The Max Fanout column lists the maximum fanout for buffer tree 
creation.

Action Column
The Action column lists the action command to the Silicon Expert. The 
user can select the type of action that can be applied for the network.

Finish Button
Click the Finish button to finish the design with all actions performed 
up to this point.

Cancel Button
Click the Cancel button to cancel all actions performed on the design.

Buffer Manager 
Options

You can assign various optional constraints to your design in the 
Buffer Manager by using the The Buffer Manager Options. The Buffer 
Manager Options dialog box, shown in Figure 2-3, is displayed when 
you click the Options button on the Buffer Manager spreadsheet. 

This section describes in detail the features of the Buffer Manager 
Options dialog box.

Figure 2-3. Buffer Manager Options Dialog box
11



Chapter 2: Macro Manager
Set Global Max Fanout Box
In the Global Max Fanout box, you can globally set the maximum 
fanout for all networks on the Max Fanout column of the Macro 
Manager spreadsheet.

Minimize Size for Network Selection Box
The Minimum Size for Network Selection box displays all the networks 
with a size above or equal to the given value.

Name or Pattern of Network Driver Box
The Name or Pattern of Network Driver box displays all the networks 
with a name matching the name you enter. 

Write Netlist When you have finished with the I/O Macro Manager spreadsheet, the 
Buffer Manager spreadsheet, and have clicked the Finish button, the 
Write Netlist dialog box is displayed.

Name your netlist, select an output format, and save it. Refer to “Write 
Netlist Dialog Box” on page 49 for information on the Write Netlist 
dialog box.
12



3
Translate

The Translate function of Silicon Explorer performs the following 
functions:

• Reads netlist in EDIF, ADL, Verilog formats and writes it out as a 
netlist in EDIF, Verilog, ADL, or VHDL format.

• Provides the user the ability to convert netlist in one format to 
another.

• Enables you to select the different netlist input and output flavors.

Using Translate
You can invoke Translate three ways:

1. Select Translate from the Getting Started Dialog Box. Refer to “Show 
Getting Started Dialog Check Box” on page 5 for information on 
how to use the Getting Started Dialog Box.

2. Select Translate from the Tools menu. Refer to “Menus, Commands, 
and Shortcut Toolbar” on page 39 for information on how to use 
the Tools menu.

3. Invoke the Translate Wizard. Refer to “Macro Manager Wizard” on 
page 43 for information on how to use the Translate Wizard.

Read Netlist When Translate is invoked, the Read Netlist dialog box is displayed. 
Select the netlist you wish to translate, and open it. Refer to “Read 
Netlist Dialog Box” on page 45 for information on the Read Netlist 
dialog box.

Write a Netlist After your design is read in, the Write a Netlist dialog box is displayed. 
Name your netlist, select the output format, and save it. Refer to “Write 
Netlist Dialog Box” on page 49 for information on the Write a Netlist 
dialog box.
13





4
Design Report

Design Report performs the following:

• Reports area and timing numbers for a compiled Actel design or an 
Actel sub-design block. 

• Provides user control to most of the compile options.

Using Design Report
You can invoke Design Report three ways:

1. Select Design Report from the Getting Started Dialog Box. Refer to 
“Overview of Silicon Expert” on page 2 for information on how to 
use the Getting Started Dialog Box.

2. Select Design Report from the Tools menu. Refer to “Menus, 
Commands, and Shortcut Toolbar” on page 39 for information on 
how to use the Tools menu.

3. Invoke the Design Report Wizard. Refer to “Design Report Wizard” 
on page 44 for information on how to use the Design Report 
Wizard.

Read a Netlist When Design Report is invoked, and a netlist has not already been 
read, the Read Netlist dialog box is displayed. Select the netlist you 
wish to optimize, and open it. Refer to “Read Netlist Dialog Box” on 
page 45 for information on the Read Netlist dialog box.
15



Chapter 4: Design Report
Design Report 
Variables 
Dialog Box 

When a netlist is read, the Design Report Variables dialog box is 
displayed, as shown in Figure 4-1.

Figure 4-1. Design Report Variables Spreadsheet

The Design Report dialog box consists of the following spreadsheet 
columns and buttons:

Variable Column
The Variable column displays the variable that controls the Report 
Generator.

Value Column
The Value column displays the value that can be applied to the 
variable. You can click check boxes, select commands from drop down 
menus, or fill in blanks, as needed, to modify displayed value.

Information Column
The Information column displays a brief description of the variable and 
its function.
16



Using Design Report
Design Report 
Options

The Design Report Options Dialog Box is displayed when you click 
the Options button, located at the lower left of the Read a Netlist 
dialog box (Figure 4-1.) 

The following are descriptions of the Design Report options.

Apply Defaults 
When you click the Apply Default option, the values in the Netlist 
Options spreadsheet are reset to the default values.

Advanced 
When you click the Advanced option, additional netlister variables are 
displayed that allow advanced users more control over the netlister 
read operation.

Add Variables 
When you click the Add Variables option, you can add undocumented 
netlister variables.
17



Chapter 4: Design Report
Viewing a Report
After setting all variables in the Design Report Variables dialog box, 
click OK to generate a report. A sample report is shown in Figure 4-2.

Figure 4-2. Sample Report

A report generated by Silicon Expert Design Report consists of an Area 
report section and Timing Report section.

Area Report The Area report gives the count of sequential and combinatorial 
modules used by the design. The Area report also lists the number of 
I/O resources, clock resources, or special resources used in the design.
18



Viewing a Report
Timing Report The pre-layout estimated timing is displayed for the following path 
groups:

• Port to Port

• Port to Register

• Register to Port

• Register to Register
19





5
Touring Silicon Expert

This chapter gives usage examples for using Silicon Expert to modify a 
design. Included are steps to read a sample netlist into Silicon Expert, 
compile the netlist as a block, set I/O buffers with the I/O Macro 
Manager, save the new netlist, run a design report, use the Buffer 
Manager options, observe the changes made by Buffer Manager, flatten 
a netlist, use Buffer Manager to change fanout of a design, and save a 
log file of your session.

Reading a Netlist to Generate a Report
This section describes how to read a netlist into Silicon Expert, and 
how to use the options available in the Read Netlist dialog box.

To read your design into Silicon Expert:

1. Invoke Silicon Expert as follows:

PC
From the Windows Start bar, click Programs, click Designer R2-1998, 
and click the Silicon Expert icon in the Designer R2-1998 program 
group.

UNIX
From the command line, type the following:

expert
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Chapter 5: Touring Silicon Expert
The Silicon Expert widnow, along with the Getting Started dialog 
box is displayed, as shown in Figure 5-1.

Figure 5-1. Getting Started Dialog Box

2. Select Design Report. Click OK. This invokes the Read Netlist 
dialog box, as shown in Figure 5-2.

Figure 5-2. Read Netlist Dialog Box

3. Select Edif Netlist (*.ed*) in the Files of Type pull down menu, 
as shown in Figure 5-2.
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Reading a Netlist to Generate a Report
4. Select ACT 3 in the Family pull-down. 

5. In the Look In box, navigate to the $ALSDIR/Tutorial 
directory, and select the file c25busmaster.edn. This file is a 
EDIF file created specifically for this tour.

6. Click on the Options button at the lower right corner of the 
Read Netlist Dialog Box. This displays the Read Netlist Options 
dialog box, as shown in Figure 5-3.

Figure 5-3. Read Netlist Dialog Box

7. Select VHDL from the NETLIST_NAMING_STYLE pull-down 
menu, as shown in Figure 5-3. Click OK. 

8. In the Read Netlist Dialog Box, click Open. Confirmation that 
your netlist is opened is displayed in the Silicon Expert Window, 
and the Design Report Variables dialog box is displayed, as shown 
23



Chapter 5: Touring Silicon Expert
in Figure 5-4. In the Design Report dialog box, five variables with 
default settings are displayed. 

Figure 5-4. Design Reports Variables Dialog Box
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Generating Netlist Report for a Block
Generating Netlist Report for a Block
You can run the Design Report in block mode for a brief display of the 
timing estimates without the tool checking for I/O pads on the top 
level ports. 

To turn on the Block Compiler and compile your netlist:

1. Click the Design Report Wizard button in the toolbar, as 
shown in Figure 5-5.

Figure 5-5. Design Report Wizard

This displays the Design Report Variables dialog box, as shown in 
Figure 5-6.

Figure 5-6. Design Report Variables Dialog Box with BLOCK Selected

2. Select the Block (Block Compile) check box, as shown in 
Figure 5-6. Click OK. A complete report of the netlist is displayed, 
including sequential and total logic utilization, operating 
conditions, inpad to register, register to register, register to outpad, 
inpad to outpad, and global signal propagation delays and logic 
levels. The software automatically recognizes the global signals 
from the netlist

Design Report 
Wizard
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Setting I/O Buffers With I/O Macro Manager
This section describes how to use the I/O Macro Manager tool to set 
I/O buffer assignments and specify global networks in the design.

To Use I/O Macro Manager:

1. Select the I/O Macro Manager command from the Tools 
menu. This displays the I/O Macro Manager dialog box, as shown 
in Figure 5-7.

Figure 5-7. I/O Macro Manager Dialog Box

Examine the Current I/O column to see what type of buffers the 
software suggests. You will notice that the signals lnkclk and 
lnkres_l are automatically recognized as global signals, by 
suggesting the use of clkbuf macros. 

You are not allowed to assign macros that are illegal for a particular 
network. For example, both of the global signals in this design drive 
non-sequential macros so the HCLK is not an I/O option.

2. Click Finish, and observe the changes to the design in the 
Silicon Expert window.
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Saving a Modified Netlist
Saving a Modified Netlist 
This section shows you how to save a modified netlist. 

To save your netlist:

1. Click on the Write Netlist Wizard button in the toolbar, as 
shown in Figure 5-8. This invokes the Write Netlist dialog box, as 
shown in Figure 2.

Figure 5-8. Write Netlist button

2. In the File Name text box, change the name to c25bus_io.edn, 
as shown in Figure 5-9. Click Save.

Figure 5-9. Write Netlist Dialog Box

You will use this saved file in the next section of the tour.

Write Netlist 
Wizard Button
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Generating a Design Report
This section describes how to run a report on the design you 
completed and saved as c25bus_io.edn in the previous section.

To invoke Design Report:

1. Click on the Design Report Wizard button in the toolbar, as 
shown in Figure 5-10.

Figure 5-10. Design Report Wizard

This displays the Design Report Variables dialog box, as shown in 
Figure 5-11.

Figure 5-11. Design Report Variables dialog box

2. Deselect Block (for Block Compile) in the Design Reports 
Variable dialog box, so that there is no check in the value box. 
Click OK, and observe the contents of the Silicon Expert window. 
Observe I/O and clock utilization for this design, and timing 
estimates in the Silicon Expert window for inpad to gated, inpad to 
clock, inpad to async, inpad to outpad, clkbuf to outpad, clock to 
outpad, and register to register. 

Design Report 
Wizard
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Using The Buffer Manager Options
Using The Buffer Manager Options
This section describes how to use the Buffer Manager options on the 
netlist C25bus_io.edn to balance buffer trees or correct fanout 
violations.

To invoke Buffer Manager:

1. Select Buffer Manager from the Tools menu. This displays the 
Buffer Manager dialog box, as shown in Figure 5-12.

Figure 5-12. Buffer Manager Dialog Box

2. Click on the options button in the Buffer Manager dialog box. 
This displays the Buffer Manager Options dialog box, as shown in 
Figure 5-13.

Figure 5-13. Buffer Manager Options Dialog Box
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Chapter 5: Touring Silicon Expert
3. Set Global Max fanout to 4, and Minimum Size for Network 
selection to 4. Click OK. 

The Buffer Manager Dialog Box is displayed, as shown in Figure 5-
14, showing a list of all the macros that drive a network with a 
fanout greater or equal to 4.

In the Action column, actions that are recommended by the 
software are displayed. For example, the network driver from 
U1308:Y has a fanout of 10, which is greater than the Global Max 
Fanout of 4, so the recommended action is to balance the buffer 
tree. 

Figure 5-14. Buffer Manager Dialog Box

Click Finish to accept the defaults. In the Silicon Expert window, the 
networks that were edited are displayed. 
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Observing Changes Implemented by Buffer Manager
Observing Changes Implemented by Buffer Manager
This section describes how to observe the fanout and buffer changes 
implemented by Buffer Manager to the design c25bus_io.edn.

To see changes made by Buffer Manager:

1. Select Buffer Manager from the Tools menu. This displays the 
Buffer Manager dialog box, as shown in Figure 5-15.

Figure 5-15. Buffer Manager Dialog Box

Observe the changes that have been implemented. The buffers on 
Network column now read 6 for the network driven by U1308:Y. 
Since this is a hierarchical design, the buffering is done by 
considering a pin of a hierarchical block to be a load of one. Buffers 
are therefore inserted at each hierarchical port in addition to what 
is needed to balance the tree.
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Chapter 5: Touring Silicon Expert
Saving The 
Netlist

If you wish to preserve the changes made in Buffer Manager, you can 
save the netlist.

To re-name and save the netlist:

1. Click on the Write Netlist Wizard button in the toolbar, as 
shown in Figure 5-16.

Figure 5-16. Write Netlist button

This invokes the Write Netlist dialog box, as shown in 
Figure 5-17. 

Figure 5-17. Write Netlist Dialog Box

2. In the File Name text box, change the name to 
c25bus_io_buf.edn. Click Save.

Write Netlist 
Wizard Button
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Flattening a Netlist
Flattening a Netlist
For some applications, you may wish to remove the hierarchy in a 
design, and save it as a flat netlist. You can perform the following steps 
to flatten a netlist. 

Opening the 
Previous Netlist

For this example, the netlist previously saved as c25bus_io.edn will be 
opened, and then flattened, using the Write Netlist Options.

To Open the netlist c25bus_io.edn:

1. Click on the Read Netlist Wizard button in the toolbar, as 
shown in Figure 5-18.

Figure 5-18. Read Netlist button

Read Netlist 
Wizard Button
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Chapter 5: Touring Silicon Expert
This invokes the Read Netlist dialog box, as shown in 
Figure 5-19 Select the file c25bus_io.edn. Click Open. 

Figure 5-19. Read Netlist Dialog Box

Flattening the 
Netlist using 
Write Netlist 
Options

The netlist c25bus_io.edn will be flattened and saved using the Write 
Netlist option.

To invoke the Write Netlist dialog box:

1. Click on the Write Netlist Wizard button in the toolbar, as 
shown in Figure 5-20.

Figure 5-20. Write Netlist button

Write Netlist
Wizard Button
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Flattening a Netlist
This invokes the Write Netlist dialog box, as shown in 
Figure 5-21.

Figure 5-21. Write Netlist Dialog Box

2. In the Write Netlist dialog box, select Options. This displays the 
Write Netlist Options dialog box, as shown in Figure 5-22.

Figure 5-22. Write Netlist Options Dialog Box
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3. In the Write Netlist dialog box, click on the options pull-down 
and select advanced, as shown in Figure 5-22. This displays 
advanced features of the Write Netlist Options dialog box, as shown 
in Figure 5-23.

Figure 5-23. Write Netlist Options with Advanced Features Enabled

4. Turn on the flatten netlist feature by clicking the value for 
FLAT, so that a check appears in the box, as shown in Figure 
5-23. Click OK. 

5. In the File Name text box, change the name to 
c25bus_io_flat.edn, as shown in Figure 5-24. Click OK. This 
creates a flat EDIF netlist. .

Figure 5-24. Write Netlist Dialog Box
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Using Buffer Manager to Change Fanout of the Design
Using Buffer Manager to Change Fanout of the Design
You can use the Buffer Manager to change the global fanout of the 
non-hierarchical design in memory from the previous steps, as follows:

To invoke the Buffer Manager tool:

1. Select Buffer Manager from the Tools menu. This displays the 
Buffer Manager dialog box, as shown in Figure 5-25.

Figure 5-25. Buffer Manager Dialog Box

2. Click the options button in the Buffer Manager dialog box. 
This displays the Buffer Manager Options dialog box, as shown in 
Figure 5-13.

Figure 5-26. Buffer Manager Options Dialog Box

3. Ensure that Global Max fanout is set to 4, and Minimum size 
for Network Selection is set to 4, as shown in Figure 5-26. 
Click OK. 
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4. Accept the defaults in the Buffer Manager dialog box. Click 
Finish.

Saving a Log File of Your Session
This section describes how save a text log file of your session. 

To save a log file:

1. Select the Save Report As command from the File Menu. This 
invokes the Export Report dialog box, as shown in Figure 5-27. 
Navigate to a directory, specify a file name, and click Save.

Figure 5-27. Export Report Dialog Box

You can refer to this text file and view the actions that you have 
performed to see the current state of your netlist.
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Menus, Commands, and Shortcut Toolbar

Features of Silicon Expert can be invoked using Silicon Expert menus. 
This appendix describes Silicon Expert menus, commands, and the 
shortcut toolbar.

File Menu The File menu is shown in Figure A-1.

Figure A-1. File Menu

Read Netlist
The Read a Netlist command invokes the Read Netlist dialog box. Refer 
to “Read Netlist Dialog Box” on page 45 for more information on the 
Read Netlist dialog box.

Write Netlist
The Write a Netlist command invokes the Write a Netlist dialog box. 
Refer to “Write Netlist Dialog Box” on page 49 for more information on 
the Write Netlist dialog box.

Save Report As
The Save Report As command allows you to save a report as a .rpt file, 
using your netlist name or a name other than your netlist. Refer to 
“Design Report” on page 15 for more information on reports generated 
by Silicon Expert.

Exit
The Exit command allows you to exit Silicon Expert.
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Appendix A: Menus, Commands, and Shortcut Toolbar
Edit Menu The Edit menu is shown in Figure A-2.

Figure A-2. Edit Menu

Clear
The Clear command clears the information displayed on the Silicon 
Expert window. Refer to “Overview of Silicon Expert” on page 2 for 
more information on the Silicon Expert window.

Tools Menu The Tools menu is shown in Figure A-3.

Figure A-3. Tools menu

Macro Manager
The Macro Manager command invokes the Macro Manager function of 
Silicon Expert. Refer to “Macro Manager” on page 7 for more 
information on Macro Manager.

Translate
The Translate command invokes the Translate Function of Silicon 
Expert. Refer to “Translate” on page 13 for more information on 
Translate.
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Design Report
The Design Report command invokes the Design Report function of 
Silicon Expert. Refer to “Design Report” on page 15 for more 
information on Design Report.

I/O Macro Manager
The I/O Macro Manager command invokes the I/O Macro Manager 
dialog box. Refer to “I/O Macro Manager Dialog Box” on page 8 for 
more information on the I/O Macro Manager dialog box.

Buffer Manager
The Buffer Manager command invokes the Buffer Manager dialog box. 
Refer to “Buffer Manager Dialog Box” on page 10 for more information 
on the Buffer Manager dialog box.

Options Menu The Options menu is shown in Figure A-4.

Figure A-4. Options Menu

Show Getting Started Dialog
The Show Getting Started Dialog command allows you to disable the 
Getting Started box the next time you invoke Silicon Expert. Refer to 
“Overview of Silicon Expert” on page 2for more information on the 
Show Getting Started dialog box.
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Help Menu The Help menu is shown in Figure A-5.

Figure A-5. Help Menu

Help Topics
The Help Topics command invokes the Silicon Expert On-Line Help. 
Refer to “On-Line Help” on page viii in the Introduction chapter for 
more information on On-Line Help.

About Silicon Expert
The About Silicon Expert command lists information about this release 
of Silicon Expert.

Silicon Expert Shortcut Toolbar
A shortcut toolbar is located on the Silicon Expert window. By clicking 
in the buttons on the shortcut toolbar, you can invoke functions of 
Silicon Expert. The Silicon Expert shortcut toolbar is shown in Figure 
A-6.

Figure A-6. Silicon Expert Shortcut Toolbar

Read a Netlist 
Button

The Read Netlist button invokes the Read Netlist dialog box. Refer to 
for more information on the Read Netlist dialog box.
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Silicon Expert Shortcut Toolbar
Write a Netlist 
Button

The Write a Netlist button invokes the Write a Netlist dialog box. Refer 
to “Write Netlist Dialog Box” on page 49 for more information on the 
Write a Netlist dialog box.

Silicon Expert 
Wizard Buttons

Silicon Expert offers wizards to guide you through all of the steps 
associated with using of the I/O Macro Manager, Translate, and Design 
Report functions. Silicon Expert Wizard buttons are shown in
Figure A-7. 

Figure A-7. Silicon Expert Wizard Buttons

Macro Manager Wizard
The Macro Manager Wizard button invokes the Macro Manager Wizard. 
The Macro Manager Wizard steps you through the Macro Manager 
process, including reading a netlist, displaying the I/O Macro Manager 
spreadsheet, displaying the Buffer Manager spreadsheet, and writing a 
netlist. The Macro Manager Wizard flow is shown in Figure A-8.

Figure A-8. Macro Manager Wizard Flow

Macro 
Manager 
Wizard

Translate 
Wizard

Design Report 
Wizard

Read a Netlist

I/O Macro 
Manager

Buffer 
Manager

Write a Netlist
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Translate Wizard
The Translate Wizard button invokes the Translate Wizard. The 
Translate Wizard steps you through the Translate process, including 
reading a netlist and writing a netlist in a different netlist format. The 
Translate Wizard flow is shown in Figure A-9.

Figure A-9. Translate Wizard flow

Design Report Wizard
The Design Report Wizard button invokes the Design Report Wizard. 
The Design Report Wizard steps you through the Design Report 
process, including reading a netlist and displaying the design report. 
The Design Report flow is shown in Figure A-10.

Figure A-10. Design Report Flow

Help Button The Help button invokes Silicon Expert context-sensitive on-line help. 
After clicking this button, place the cursor over any item of a screen in 
Silicon Expert, and click again. A help topic will appear to give 
information about the item. Refer to “On-Line Help” on page viii for 
more information about Silicon Expert on-line help.

Read a Netlist Write a Netlist

Read a Netlist Report
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B
Read Netlist Dialog Box

This appendix describes the Read Netlist dialog box and its options.

When you select Macro Manager, Translate, or Design Report, the Read 
Netlist dialog box is displayed. The Read Netlist dialog box is shown in 
Figure B-1. 

In the File Name box, enter the name of the netlist you wish to open, 
or use the Files of Type box to select the type of netlist file you wish to 
open (EDIF, Verilog, or ADL), and use the Look In box to navigate to 
the desired .edn file.

In the Family box, select the Actel device family from the pull-down 
menu. Click Open to open the netlist.

Figure B-1. Read a Netlist Dialog Box
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Appendix B: Read Netlist Dialog Box
Read Netlist 
Options
Dialog Box

The Read Netlist Options dialog box is displayed when you click the 
Options button, located at the lower right of the Read Netlist dialog 
box. The options are available when EDIF or ADL is selected in the 
File of Type box. The Read Netlist Options dialog box is shown in 
Figure B-2.

Figure B-2. Read Netlist Options Spreadsheet

The following are descriptions of the Read Netlist Options spreadsheet 
columns.

Variable Column
The Variable column lists the variables that control the netlist reader.

Value Column
The Value column displays values that can be changed and applied for 
a netlister variable. You can double-click check boxes, select 
commands from drop down menus, or fill in blanks to modify 
displayed values.

Information Column
The Information column displays a brief description of the variable and 
its function.
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Additional 
Read Netlist 
Options

Additional options are displayed in the pull down menu in the lower 
left portion of the Read Netlist Spreadsheet (Figure B-2). 

The following are descriptions of the additional option selections.

Apply Defaults 
When you click the Apply Default option, the values in the Netlist 
Options spreadsheet are reset to the default values.

Advanced 
When you click the Advanced option, additional netlister variables are 
displayed that allow advanced users more control over the netlister 
read operation.

Add Variables 
When you click the Add Variables option, you can add undocumented 
netlister variables.
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C
Write Netlist Dialog Box

This appendix describes the Write Netlist dialog box and its options.

After a design is optimized with Macro Manager or Translate, you can 
write an optimized netlist file, which can be read into Designer 
software for design implementation. The Write Netlist dialog box is 
shown in Figure C-1.

In the File Name box, enter the name of the netlist you wish to save, or 
use the Save as Type box to select the type of netlist file you wish to 
save (EDIF, Verilog, VHDL, or ADL), and use the Save In box to 
navigate to the desired directory in which to save your netlist file. Click 
Save to save the netlist.

Figure C-1. Write Netlist Dialog Box

Write Netlist 
Options Dialog 
Box

The Write a Netlist Options dialog box is displayed when the Options 
button, located at the lower right of the Write a Netlist dialog box, is 
clicked. The options are available when EDIF or ADL is selected in the 
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Appendix C: Write Netlist Dialog Box
File of Type box. The Write Netlist Options dialog box is shown in 
Figure C-2.

Figure C-2. Write Netlist Options Dialog Box

The following are descriptions of the Write Netlist Options spreadsheet 
columns.

Variable Column
The Variable column lists the variables that control the netlist reader.

Value Column
The Value column displays values that can be changed and applied for 
a netlister variable. You can click check boxes, select commands from 
drop down menus, or fill in blanks, as needed, to modify displayed 
value.

Information Column
The Information column displays a brief description of the variable and 
its function.

Additional 
Write Netlist 
Options

Additional options are displayed in the pull down menu in the lower 
left portion of the Write a Netlist Options dialog box. 

The following are descriptions of the additional option selections.

Apply Defaults 
When you click the Apply Default option, the values in the Netlist 
Options spreadsheet are reset to the default values.
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Advanced 
When you click the Advanced option, additional netlister variables are 
displayed which allow advanced users more control over the netlister 
read operation.

Add Variables 
When you click the Add Variables option, you can add undocumented 
netlister variables.
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D
Product Support

Actel backs its products with various technical support services 
including a Web site, monthly Fax Broadcast, a fax back service, a 
bulletin board system, electronic mail, Customer Service, and a 
Customer Applications Center.

Actel U.S. Toll-Free Line
Use the Actel toll-free line to contact Actel for sales information, 
technical support, requests for literature about Actel and Actel 
products, Customer Service, investor information, and using the Action 
Facts service.

The Actel Toll-Free Line is (888) 99-ACTEL.

Customer Service
Contact Customer Service for non-technical product support, such as 
product pricing, product upgrades, update information, order status, 
and authorization.

From Northeast and North Central U.S.A., call (408) 522-4480.
From Southeast and Southwest U.S.A., call (408) 522-4480.
From South Central U.S.A., call (408) 522-4474.
From Northwest U.S.A., call (408) 522-4434.
From Canada, call (408) 522-4480.
From Europe, call (408) 522-4474 or +44 (0) 1256 305600.
From Japan, call (408) 522-4252.
From the rest of the world, call (408) 522-4252.
Fax, from anywhere in the world (408) 522-8044.
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Customer Applications Center
The Customer Applications Center is staffed by applications engineers 
who can answer your hardware, software, and design questions.

All calls are answered by our Technical Message Center. The center 
retrieves information, such as your name, company name, phone 
number and your question, and then issues a case number. The Center 
then forwards the information to a queue where the first available 
application engineer receives the data and returns your call. The 
phone hours are from 7:30 a.m. to 5 p.m., Pacific Standard Time, 
Monday through Friday.

The Customer Applications Center number is (800) 262-1060.

European customers can call +44 (0) 1256 305600.

Guru Automated Technical Support
Guru is a Web based automated technical support system accessible 
through the Actel home page (http://www.actel.com). Guru provides 
answers to technical questions about Actel products. Many answers 
include diagrams, illustrations and links to other resources on the Actel 
Web site. Guru is available 24 hours a day, seven days a week.

Action Facts
Action Facts is a 24-hour fax-back service that allows you to have 
technical literature faxed directly to you. The literature includes current 
applications notes, device diagrams, radiation testing reports, CAE-
related documents, training release schedules, and much more. 

To receive your free copy of the catalog or any of our literature, 
contact us at (800) 262-1062 or (408) 739-1588.
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Web Site
Web Site
Actel has a World Wide Web home page where you can browse a 
variety of technical and non-technical information. Use a Net browser 
(Netscape recommended) to access Actel’s home page. The URL is 
http://www.actel.com. You are welcome to share the resources we 
have provided on the net. 

Be sure to visit the “Actel User Area” on our Web site, which contains 
information regarding: products, technical services, Designer’s Digest, 
current manuals, and release notes.

FTP Site
Actel has an anonymous FTP site located at ftp://ftp.actel.com. You 
can directly obtain library updates (such as VITAL), software patches, 
design files, and data sheets.

Electronic Mail
You can communicate your technical questions to our e-mail address 
and receive answers back by e-mail, fax, or phone. Also, if you have 
design problems, you can e-mail your design files to receive assistance. 
The e-mail account is monitored several times per day. 

The technical support e-mail address is tech@actel.com.
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Appendix D: Product Support
Worldwide Sales Offices

Actel Corporation
955 East Arques Avenue
Sunnyvale, California 94086
USA
Toll Free: 888.99.ACTEL
Tel: 408.739.1010
Fax: 408.739.1540

Actel Europe, Ltd.
Daneshill House, Lutyens Close
Basingstoke,
Hampshire RG24 8AG
United Kingdom
Tel: +44 (0)1256.305600
Fax: +44 (0)1256.355420

Actel Asia-Pacific
EXOS Ebisu Building 4F
1-24-14 Ebisu Shibuya-ku
Tokyo 150 Japan
Tel: +81 (0)3.3445.7671
Fax: +81 (0)3.3445.7668

California (North)
Tel: 408.328.2200
Fax: 408.328.2358

France
Tel: +33 (0)1.40.83.11.00
Fax: +33 (0)1.40.94.11.04

Korea
Tel: +82 (0)2.555.7425
Fax: +82 (0)2.555.5779

California (South)
Tel: 714.727.0470
Fax: 714.727.0476

Germany
Tel: +49 (0)8165.9584.0
Fax: +49 (0)8165.9584.10

Taipei, Taiwan R.O.C.
Tel: +886 (0)2.698.2448
ext. 104
Fax: +886 (0)2.698.2548

Georgia
Tel: 770.844.4495
Fax: 770.844.1395

Italy
Tel: +39 (0)2.38.09.32.59
Fax: +39 (0)2.38.09.32.60

Illinois
Tel: 847.259.1501
Fax: 847.259.1572

Massachusetts
Tel: 508.635.0010
Fax: 508.635.9510

Texas
Tel: 972.235.8944
Fax: 972.235.9659
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